Page 1 of 1

5 Volt Turn-on Time

Posted: Fri Jul 19, 2013 11:13 am
by danlee58
I'm using a SuperPro board with a custom Arduino shield. I have one part on the shield that operates at 5 Volts. It's output is pulled up to 3.3 Volts, and feeds P1.18 on the CPU.

I have had several failures of that specific part, and suspect that the 3.3 Volts is active before the 5 Volts.

Is it likely that the 5 Volt source is delayed compared to the 3.3 Volts?

When programming the unit is powered through the USB.

Re: 5 Volt Turn-on Time

Posted: Fri Jul 19, 2013 2:21 pm
by basicchip
On the SuperPRO the 5V regulator supplies the input voltage to the 3.3V regulator. So it would have to come up later.

Is the SuperPRO providing the 5V to your other circuit?

What size is the pullup?

Re: 5 Volt Turn-on Time

Posted: Sun Jul 21, 2013 12:23 am
by danlee58
The pullup is 2.2K Ohms. After correspondence with the chip manufacturer, I'm going to change the pullup to 10K, and pull it to 5V instead of 3.3V. I'll use 20k tail to ground, so the voltage at the junction, that feeds P1.18 doesn't exceed 3.3 Volts.

If I am powering the unit with only the USB, while programming, does the 5 Volts to the shield get to full voltage. If it falls below 4.5 Volts with 3.3 Volts on the output pin, that will damage the part.

Re: 5 Volt Turn-on Time

Posted: Sun Jul 21, 2013 2:37 am
by basicchip
It's better to pull it to the supply of the CPU

the CPU can handle 5V inputs as long as its power is on. If its power is off you are effectively trying to power the device through its inputs, which is not a good idea.